Re: 4.9-stabie: stabil im single-user-mode; freeze im multiuser-Betrieb?

From: Andreas Braukmann <braukmann(at)tse-online.de>
Date: Thu, 11 Dec 2003 17:38:52 +0100

Moin,

--On Mittwoch, 10. Dezember 2003 23:14 Uhr +0100 Andreas Braukmann <braukmann(at)tse-online.de> wrote:

>> DDB wre gut, um festzustellen, ob das System komplett einfriert,
>> oder nur ein Deadlock vorliegt.
>
> beenden. Nach dem Einfrieren sieht es erst so aus, als ob
> auch das "break to debugger" nicht mehr moeglich waere.
> Ich wollte (nach einigen Minuten) gerade den reset-Knopf
> betaetigen, als der Debugger doch noch "erschien". Aber
> er liess sich dann nicht bedienen. Ich hab mal noch ein
> paar Zeichen eingetippt und bin dann nach hause gefahren.
> Mal schauen, ob die Kiste die Eingaben bis morgen Mittag
> verarbeitet hat und sie am Debugger-Prompt auftauchen ...

Die Zeichen sind nicht aufgetaucht.
Inzwischen hatte ich aber "Glueck" und habe einen reprodu-
zierbaren backtrace, der auf den bge(4)-Treiber deutet.
Da wundert es mich umsomehr, dass das Problem im single-
user-Modus so viel seltener auftritt als im multi-user-
Betrieb. (Ich habe im single-user-Modus ja sogar cvsup-
Laeufe und scp-Vorgaenge hinbekommen.) Im multiuser-Be-
trieb tritt der Haenger reproduzierbar innerhalb einstel-
liger Minutenzahlen auf.

Der Trace (als erstmal unvollstaendiger Handabschrieb) sieht
so aus:

scgetc(...)
sckbdevent(...)
atkbd_intr(...)
atkbd_isa_intr(...)
Xresume1(...)
--- interrupt, eip = ..., esp = ..., ebp = ... ---
(das war dann wohl der Eintritt in den Debugger)
weiter gehts mit:
bge_miibus_readreg(c3407780,1,19,c02c2d90,c01560a3) at bge_miibus_readreg+0x7f
MIIBUS_READREG(...)
miibus_readreg(...)
MIIBUS_READREG(...)
brgphy_status(...)
brgphy_service(...)
mii_pollstat(...)
bge_tick(...)
softclock(...)
doreti_swi(...)
idle_loop()

Gibt das irgendwelche Hinweise?
Ich habe in der Vergangenheit zwar schon von bge-Problemen unter
-stable gelesen, aber das ist schon laenger her und es wurden andere
Symptome beschrieben.

-Andreas

To Unsubscribe: send mail to majordomo.FreeBSD.org
with "unsubscribe de-bsd-questions" in the body of the message
Received on Thu 11 Dec 2003 - 17:42:21 CET

search this site