Re: was isn libMagick++-6.Q*.so? Wie bekomme ich die?!

From: Oliver Fromme <oliver(at)fromme.com>
Date: Thu, 10 Dec 2015 18:41:37 +0100 (CET)

Heino Tiedemann wrote:
> Oliver Fromme <oliver(at)fromme.com> wrote:
>
> > Heino Tiedemann wrote:
> > > Mich wundert eh, das das nur mir aufgefallen ist.
> >
> > Geht mir ständig so. :-)
>
> Ich frage mich dann immer: _An wen_ muss der Bugreport.

Prinzipiell an den, der für den Code verantwortlich ist,
in dem sich der Bug befindet.

Bei Bugs in Ports erstmal an den ursprünglichen Autor.
In Ausnahmefällen kann der Port-Maintainer einen Patch in
den Port aufnehmen, z.B. wenn der Autor nicht erreichbar
ist oder aus anderen Gründen den Bug nicht fixt, oder
wenn es sich um eine dringende Sache handelt (z.B.
sicherheitsrelevant) und man nicht auf den Upsream-Fix
warten möchte.

Problematisch wird's natürlich, wenn man nicht weiß, wo
sich der Bug befindet bzw. wer oder was verantwortlich ist.
Da kann man dann nur hoffen, Gleichgesinnte zu finden,
in einem geeigneten Nutzerforum oder so.

> Mit RawThreapee hatte ich das gleiche: Ab Versuin 4.1: Alle Bilder
> wurden zu hell.

Klingt nach einer fehlerhaften (oder fehlenden) Gamma-
korrektur. Oder irgendwas mit dem Farbmanagement,
falsches Color-Profile oder so. Aber das ist jetzt
nur ins Blaue hinein geraten.

Ich hatte nach einem Update irgendwann auch mal ein
Problem mit den Farben. Es stellte sich heraus, dass
die neue Version Color-Management unterstütze. Das ist
ja erstmal eine tolle Sache, nur erfordert es dann auch,
das Farbprofil für den Monitor richtig zu konfigurieren.
Nachdem das erledigt war, klappte es auch mit den Farben,
und der angenehme Nebeneffekt war, dass die Farben dann
beim Drucken viel besser mit denen auf dem Bildschirm
übereinstimmten.

Was ich damit sagen will: Es muss nicht unbedingt ein
Bug sein. Möglicherweise ist es auch ein neues Feature,
das nur erstmal konfiguriert werden möchte. Aber das
erfährt man in der Regel, wenn man sich an die Community
der entsprechenden Software (Forum, Mailingliste, ...)
wendet.

> Gefühlt hatte das problem NUR ICH! Also liegt es irgendwei an meinem
> System - denke ich dann...

Naja ... Wenn andere Nutzer derselben Software in derselben
Version das Problem nicht haben, dann ist es schon naheliegend,
dass es irgendwie an Deinem System liegt. Es kann natürlich
auch eine Unverträglichkeit mit einer Dependency oder einer
anderen Komponente sein, d.h. man müsste auch die Versionen
der anderen Packages vergleichen. Oder es liegt an einer
bestimmten Option, mit der der Port gebaut wurde.

Das ist alles leider nicht ganz trivial.

> Aber im allgemeinen ist es Doof, den Software nicht funktioniert.

Ich kann mich nie entscheiden, was schlimmer ist, Software
oder Hardware.

Gruß
   Olli

-- 
Oliver Fromme, Mnchen   --   FreeBSD + DragonFly BSD
``We are all but compressed light'' - Albert Einstein
To Unsubscribe: send mail to majordomo(at)de.FreeBSD.org
with "unsubscribe de-bsd-questions" in the body of the message
Received on Thu 10 Dec 2015 - 18:41:40 CET

search this site