NFS

From: Patric Mrawek <patric(at)argv.de>
Date: Mon, 24 Mar 2003 17:28:26 +0100

Hi,

seit Kurzem habe ich ein Problem mit NFS-Mounts, was mir bis jetzt so
noch nicht begegnet ist.

Es gibt einen NFS-Server mit entsprechenden Exports und verschiedene
NFS-Clients. Der Server ist ein -current von vor ein paar Tagen, die
Clients -DP1 und -DP2.

Ich mounte nun ein Share und kopiere Daten von diesem Share auf die
lokale Platte auf dem Client.

# find -x -d /nfs-mnt | cpio -pdumv .

(Dabei bin ich vom NFS-Server aus auf dem Client per ssh eingeloggt.)

Nun passiert es, dass der Kopiervorgang immer an der gleichen Stelle
abbricht bzw. blockiert. Im Log findet sich:

bowmore kernel: nfs server talisker:/usr/src: not responding 10 > 9

Da ich intr,soft gemoutet habe kann ich das Kopieren abbrechen. Starte
ich den Kopiervorgang sofort neu passiert nichts. Warte ich aber ca.
30 Sekunden kann ich wieder bis zum dem Punkt kopieren, an dem es
vorher auch blockiert hat.

Ich kann den Fortschritt beim Kopieren durch die Anzahl der
nfsd-Prozesse beeinflussen. D.h. bei /usr/sbin/nfsd -u -t -n 4
blockiert das Kopieren frueher als bei einem /usr/sbin/nfsd -u -t -n 8.

Von einem anderen Client aus kann ich das Phaenomen reproduzieren. Es
deutet also daraufhin, dass der Server montags etwas lustlos ist.

Netzwerkprobleme gibt es mit keiner der beteiligten Maschinen und es
sind auch keine Realtek-Karten im Spiel :-)

Auch das Kopieren einer groesseren Datenmenge vom Server zum Client mit z.B.

# find -x -d . | cpio -o -H newc | ssh root(at)client "cd /spare; cpio -idumv"

klappt problemlos.

Any ideas?

Patric

-- 
The problem with troubleshooting is that trouble shoots back.
To Unsubscribe: send mail to majordomo(at)de.FreeBSD.org
with "unsubscribe de-bsd-questions" in the body of the message
Received on Mon 24 Mar 2003 - 17:28:31 CET

search this site