Re: am upgrading from 2.2.7-STABLE to -current, any trouble to expect ?

From: <Marc_van_Woerkom(at)>
Date: Thu, 5 Nov 1998 14:06:38 +0200

Marc van Woerkom
05.11.98 14.06

Two days ago, I cvsuped -current, coming from a freshly built 2.2.7
with i4b driving a Teles ISDN card. Yesterday I reported my troubles
- buildworld ran fine, installworld & kernel build processes hanged
at various stages - to the de-bsd-questions list.

In the meantime I succeded to build a working 3.0-current, alas with
dysfunctional i4b (see your remark below):

A) Running a decent 3.0 (aout)

Main cause of my problems seems to be the "chicken and egg" type of
problem that the 3.0 build process (as of 2/3th November) needs certain
tools (and maybe even kernel calls) in 3.0 flavour ideally all these
critical targets would be build and installed first, to have a working
set of tools. At least in my case, the build process did not work
this way.

So I took a -current kernel from September, when I last attempted
to upgrade, and used the boot loader from a 3.0 boot floppy to
fire up my system (older -current kernel, up to date -current sources
and a mix of -current and -stable tools and libraries).

This worked out, and I was able to track down tools that had to be
ugraded to 3.0 (e.g. cd ../kbdcontrol; make; make install) by

Some makefiles in the /modules section had to be modified too,
they produced *.ko results but tried to install without this
suffix (e.g. 'linux' instead of 'linux.ko'):

After lots of iterations, make installworld finally ran smooth,
and I was able to produce an up to date GENERIC kernel, that
worked fine after reboot.

B) Running X11 on top of it

To make X11, windowmaker and wdm working again, I had
to move /usr/X11R6/lib/lib* to /usr/X11R6/lib/aout,
the same for /usr/local/lib.

Gimp, Emacs, xcdplayer etc. work fine, Netscape Communicator 4.5 is
the only X11 app so far that seems not to work. I'll try a reinstall
of the package later, followed by a recompilation of X11 (btw 3.3.3
is expected this month)

C) Building a customized kernel with i4b

When rebuilding -stable, all I had to do was running i4b's
and again, eventually rebuilding i4b and so it was easy to
build the kernel.

Now there is a little problem, in that i4b modifies 5 files and
stores -BACKUP versions of them. These backups were 2.2.7 versions,
and the the script is not able to figure out, that
it should not replace those 3.0 files (flooded in via cvsup) with
the outdated backups.
Removed the backups and removed some lines at the end of
options.i386 that were already present from the prior 2.2.7

By comparison with -current GENERIC and -current LINT, I was able
to upgrade my old CUSTOM config to -current.

> Oh yeah, and delete the "vector isicintr" from your kernel config file.

This is one of the things I infered from comparison.

Where I was unsure was:

I put a sppp device into the config file, but no ppp and no tun
devices - is this OK?

The so won kernel compiled and booted properly, but i4b did not
work properly, it hung after the "dialing 0123.." message.

It's likely I ran into this:

> Be aware that you have to modify i4b_isic.c (I already sent a
> patch to the list) to register the interrupt handler.

Alas I had no trouble here:

> There was also a problem with compiling isdnd because no is
> generated under -current. A patch for this was also sent to the
> list.

Compiling isdnd was no problem.

Received on Thu 05 Nov 1998 - 14:07:08 CET

search this site